Tuesday, 23 October 2018: Magento 2 Frontend Development I training in BirkStaete Soest, Nederland » More information

End-of-life for Joomla! 1.5 extensions

The Joomla! project is moving forwards to version 3.0 and version 1.5 has been declared obsolete in April 2012. So where does this leave the compatibility for all Yireo extensions?

The issue of compatibility

If all extensions would be compatible with all versions of Joomla!, there won't be such an issue with this. However, the Joomla! core has changed dramatically from Joomla! 1.5 to later versions (Joomla! 1.6, Joomla! 1.7, Joomla! 2.5, Joomla! 3.0). This has required extension-developers to either write extensions for both architectures (1.5 and 1.6+) or construct complex mechanisms (if-else statements in PHP; separate XML-files). In basics, it is difficult to maintain Joomla! 1.5 compatibility. We will therefor (just like many other extension developers) drop Joomla! 1.5 compatibility per extension.

MageBridge and Joomla! 1.5

Our main extension MageBridge will hit milestone-version 1.8 at the end of August. It will remain compatible with Joomla! 1.5 even through the release of 1.9. However, work on MageBridge 2.0 will be started shortly, and with that release major parts of MageBridge will be rewritten - but only for Joomla! 2.5 and upwards. We are planning to release MageBridge 2.0 in the beginning of 2013, but this also depends on the release of Magento 2.0.

Other commercial extensions and Joomla! 1.5

Our commercial extensions like Dynamic404, TweetScheduler, GoogleTranslate and BingTranslate wil be dropping Joomla! 1.5 compatibility in September 2012. New features will only be implemented in packages for Joomla! 2.5 and upwards. Support for Joomla! 1.5 will still be available until furter notice.

SimpleLists and Joomla! 1.5

SimpleLists will be focussing on newer versions of Joomla!, and dropping support for Joomla! 1.5 in August 2012. Support for Joomla! 1.5 will not be given anymore, and new features will only be implemented in packages for Joomla! 2.5 and upwards. Support for Joomla! 1.5 will only be made available for customers who purchase the SimpleLists Pro subscription, which will be made available prior to the end-of-life of Joomla! 1.5 support.

Other free extensions and Joomla! 1.5

Last but not least, we have a great bunch of extensions that are free as in beer and as in freedom: SSLRedirect, Fancybox, ScriptMerge, HTTPAuthentication and few others. For those extensions, Joomla! 1.5 compatibility will be simply dropped.

Written by Jisse Reitsma op 20 June 2012

Looking for a training in-house?
Let's get to it!