Friday, 31 August 2018: Magento 2 Frontend Development II training in BirkStaete Soest, Nederland » More information

Raising the bar with Joomla 3 and PHP 5.4

This is an announcement that we are raising the bar. As of June 1st, 2015, few days ago, we are dropping all support for Joomla 2.5 and PHP 5.3. Anyone still on those deprecated versions will not be able to use our new Joomla extension versions or receive support. Here's why.

Joomla 2.5 is outdated

Joomla 3.0.0 was released in September 2012 (almost 3 years ago) and since then, Joomla 3 has become the de-facto Joomla version - much easier to learn, faster in performance and overall a better choice. Upgrading Joomla from version 2.5 to version 3 is peanuts in most cases. However, still some site owners simply do not do this - they stick to Joomla 2.5 because not upgrading requires zero effort. Still, the same site owners keep working on their site - adding more extensions and making their site more complex. This strategy is wrong and is bound to fail. Joomla 2.5 is no longer supported by the Joomla project since end of 2014, meaning that stalling the upgrade is really a bad thing to do.

We recommend everybody that is still on Joomla 2.5 to upgrade ASAP. If you are hesitant about upgrading, please be wise and setup a testing environment first (a copy of your current Joomla 2.5 site) and see how the upgrade goes.

PHP 5.3 is outdated

Just like we are dropping Joomla 2.5 support, we are also dropping PHP 5.3 support. PHP 5.4 has been available for years, has better security and performance, and is compatible with Joomla and about 99.99% of the extensions. We have decided to make a change here, and force upgrades upon new users. We will be making use of the PHP 5.4 features like traits very soon, because it allows code to become cleaner so that the code again contains less bugs. Not updating PHP is costing money.

We recommend anyone still on PHP 5.3 to ask their hosting provider to upgrade ASAP, or to move your site to an environment that already supports PHP 5.4 or higher.

Written by Jisse Reitsma op 5 June 2015

Looking for a training in-house?
Let's get to it!